Skip to main content
Azure Public IP(s) are zone redundant free of cost natively - Generally Available

Availability zone gives high availability to an application as well as information by forestalling the physical datacenter disappointments by involving replication of the asset in extra datacenter.
Azure typically has 3 zones per region (and not all regions support zone). Thus, while setting up the environment we really want to pick the right region based on our usecase.

Public IP helps to access a resource or an application publicly.

Azure offers 2 types of SKU for public IP as below

  1. Basic
  2. Standard

Only Standard SKU gives zone facility. Basic SKU is always non-zonal and this SKU also will be retired 09/2025.

Standard public IP can be fell into any of the below category

  1. No Zone / Non-Zonal - No availability zone at all
  2. Zonal - Our services can be replicated in any one of selected zones from three zones.
  3. Zone redundant - Resource will be replicated in all 3 zones. It is opposite of "No Zone"

Unless you specifically choose or pin zone, public IP is zone redundant (i.e., single public IP is replicated in 3 zones).

I guess, as of now azure allows to select only one zone as zonal whereas you can choose more than one different zone while crating VMs

Comments

Popular posts from this blog

Avoid YAML Validation error in azure devops pipeline Hi All! Consider a scenario that you committed a YML CI/CD file on the repository with some syntax, indentation and/or other error(s). so that pipeline failed. After you find some errors and rectified in the repository file and committed again but pipeline still gets failed because some errors are still there. Now you afraid that even if you fixed error in all the places, what happens if pipeline failed again because your project lead or manager set up build notification mail trigger for build success and fails. you need to answer them for build fail reason. Azure devops pipelines offers YAML validation feature after altered and before committed and before run pipeline. To utilize this feature, what we do is, Instead of modifying the file from repository, Do as below Go to the specific build click "Edit Pipeline" Modify/fix errors and click "validate" as shown in the picture below ...
Wow! Monitor web apps running in azure VM and VMSS via app insights Hi All! Application insights monitors the telemetry of web applications, function app, APIM and etc., Consider a scenario that your organization has some web applications hosted in IIS of an azure VM and they want to monitor performance of those applications. Azure VM was not the eligible candidate to map with Application insights then how can we monitor app(s) running inside azure VM? Now azure offers the feature of monitoring azure vm's web applications through application insights generally available. Please follow the below steps and have a look into the picture You need to have a connection string of an existing application insights. If have, copy it. Go to the VM which has web apps running in IIS Click "Extension+applications" and then click Add Find Application insights agent for .NET and click next Paste the copied connection string of app insights and click Review+Cre...