Skip to main content
Glimpse - Azure function migration from .net6 in-process to .net8 isolated

Microsoft/Azure periodically announces the end of support for some services and ask us to migrate to a new version/release when they come up with a robust solution than the deprecated.

In this post we are going to see a glimpse/UI configuration change of azure function 𝗺𝗶𝗴𝗿𝗮𝘁𝗶𝗼𝗻 𝗳𝗿𝗼𝗺 .𝗻𝗲𝘁𝟲 𝗶𝗻-𝗽𝗿𝗼𝗰𝗲𝘀𝘀 𝗺𝗼𝗱𝗲𝗹 𝘁𝗼 .𝗻𝗲𝘁𝟴 𝗶𝘀𝗼𝗹𝗮𝘁𝗲𝗱. Here, I'm not going to deep dive about the migration whereas going to see the illustration of changing .net version from UI. For learning, GUI is the best place to start. So, as a dev guy we would prefer azure portal mostly.

Consider a scenario that, you're requested to migrate your existing .net6 function app to be migrated .net8 isolated, you would go to settings panel and try to change the version in configuration, but the option would be disabled, it was disabled for me initially. Shocking and Afraid! After some point of time, I followed as below illustrated.

  1. Going to Configuration and verifying .𝗡𝗲𝘁 𝟴 𝗜𝘀𝗼𝗹𝗮𝘁𝗲𝗱 - it is disabled.
  2. Going to Environment Variables section under the same settings blade.
  3.   2.1 𝘊𝘩𝘢𝘯𝘨𝘦 𝘵𝘩𝘦 𝘷𝘢𝘭𝘶𝘦 𝘧𝘳𝘰𝘮 "𝘥𝘰𝘵𝘯𝘦𝘵" 𝘵𝘰 "𝘥𝘰𝘵𝘯𝘦𝘵-𝘪𝘴𝘰𝘭𝘢𝘵𝘦𝘥" for 𝙁𝙐𝙉𝘾𝙏𝙄𝙊𝙉𝙎_𝙒𝙊𝙍𝙆𝙀𝙍_𝙍𝙐𝙉𝙏𝙄𝙈𝙀 and save it.
  4. Now, you can see .Net 8 Isolated is enabled.

You may not face this scenario, but this post will help you if you come across it.
I welcome your thoughts always.

Comments

Popular posts from this blog

Avoid YAML Validation error in azure devops pipeline Hi All! Consider a scenario that you committed a YML CI/CD file on the repository with some syntax, indentation and/or other error(s). so that pipeline failed. After you find some errors and rectified in the repository file and committed again but pipeline still gets failed because some errors are still there. Now you afraid that even if you fixed error in all the places, what happens if pipeline failed again because your project lead or manager set up build notification mail trigger for build success and fails. you need to answer them for build fail reason. Azure devops pipelines offers YAML validation feature after altered and before committed and before run pipeline. To utilize this feature, what we do is, Instead of modifying the file from repository, Do as below Go to the specific build click "Edit Pipeline" Modify/fix errors and click "validate" as shown in the picture below ...
Azure Public IP(s) are zone redundant free of cost natively - Generally Available Availability zone gives high availability to an application as well as information by forestalling the physical datacenter disappointments by involving replication of the asset in extra datacenter. Azure typically has 3 zones per region (and not all regions support zone). Thus, while setting up the environment we really want to pick the right region based on our usecase. Public IP helps to access a resource or an application publicly. Azure offers 2 types of SKU for public IP as below Basic Standard Only Standard SKU gives zone facility. Basic SKU is always non-zonal and this SKU also will be retired 09/2025. Standard public IP can be fell into any of the below category No Zone / Non-Zonal - No availability zone at all Zonal - Our services can be replicated in any one of selected zones from three zones. Zone redundant - Resource will be replicated in all 3 zones. It is opposite of...
Wow! Monitor web apps running in azure VM and VMSS via app insights Hi All! Application insights monitors the telemetry of web applications, function app, APIM and etc., Consider a scenario that your organization has some web applications hosted in IIS of an azure VM and they want to monitor performance of those applications. Azure VM was not the eligible candidate to map with Application insights then how can we monitor app(s) running inside azure VM? Now azure offers the feature of monitoring azure vm's web applications through application insights generally available. Please follow the below steps and have a look into the picture You need to have a connection string of an existing application insights. If have, copy it. Go to the VM which has web apps running in IIS Click "Extension+applications" and then click Add Find Application insights agent for .NET and click next Paste the copied connection string of app insights and click Review+Cre...